sys-apps/gawk: stable 5.0.1 for ppc64, bug #725374
[gentoo.git] / dev-libs / uriparser / uriparser-0.9.3.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit cmake-utils
7
8 DESCRIPTION="Uriparser is a strictly RFC 3986 compliant URI parsing library in C"
9 HOMEPAGE="https://uriparser.github.io/"
10 SRC_URI="https://github.com/${PN}/${PN}/releases/download/${P}/${P}.tar.bz2"
11
12 LICENSE="BSD"
13 SLOT="0"
14 KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
15 IUSE="doc qt5 test unicode"
16
17 RDEPEND=""
18 DEPEND="virtual/pkgconfig
19         doc? ( >=app-doc/doxygen-1.5.8
20                 qt5? ( dev-qt/qthelp:5 ) )
21         test? ( >=dev-cpp/gtest-1.8.1 )"
22
23 REQUIRED_USE="test? ( unicode )"
24 RESTRICT="!test? ( test )"
25
26 DOCS=( AUTHORS ChangeLog THANKS )
27
28 PATCHES=(
29         "${FILESDIR}"/${P}-tests.patch
30 )
31
32 src_configure() {
33         local mycmakeargs=(
34                 -DBUILD_SHARED_LIBS=ON
35                 -DURIPARSER_BUILD_CHAR=ON
36                 -DURIPARSER_BUILD_DOCS=$(usex doc ON OFF)
37                 -DURIPARSER_BUILD_TESTS=$(usex test ON OFF)
38                 -DURIPARSER_BUILD_TOOLS=ON
39                 -DURIPARSER_BUILD_WCHAR_T=$(usex unicode ON OFF)
40         )
41         cmake-utils_src_configure
42 }
43
44 src_install() {
45         cmake-utils_src_install
46
47         if use doc && use qt5; then
48                 dodoc "${BUILD_DIR}"/doc/*.qch
49                 docompress -x /usr/share/doc/${PF}/${P}.qch
50         fi
51 }