dev-libs/libxml2: arm64 stable (bug #701020)
[gentoo.git] / dev-libs / uriparser / uriparser-0.9.1.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 DESCRIPTION="Uriparser is a strictly RFC 3986 compliant URI parsing library in C"
7 HOMEPAGE="https://uriparser.github.io/"
8 SRC_URI="https://github.com/${PN}/${PN}/releases/download/${P}/${P}.tar.bz2"
9
10 LICENSE="BSD"
11 SLOT="0"
12 KEYWORDS="amd64 ~arm ppc ~ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
13 IUSE="doc qt5 test unicode"
14
15 RDEPEND=""
16 DEPEND="virtual/pkgconfig
17         doc? ( >=app-doc/doxygen-1.5.8
18                 qt5? ( dev-qt/qthelp:5 ) )
19         test? ( >=dev-cpp/gtest-1.8.1 )"
20
21 REQUIRED_USE="test? ( unicode )"
22 RESTRICT="!test? ( test )"
23
24 DOCS=( AUTHORS ChangeLog THANKS )
25
26 src_configure() {
27         econf \
28                 $(use_enable test) \
29                 --enable-char \
30                 $(use_enable unicode wchar_t) \
31                 $(use_enable doc) \
32                 --docdir=/usr/share/doc/${PF}/
33 }
34
35 src_install() {
36         default
37
38         if use doc && use qt5; then
39                 dodoc doc/*.qch
40                 docompress -x /usr/share/doc/${PF}/${P}.qch
41         fi
42 }