dev-libs/distorm64: Revert "drop old"
[gentoo.git] / dev-libs / unibilium / unibilium-2.0.0.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 inherit flag-o-matic
6
7 DESCRIPTION="A very basic terminfo library"
8 HOMEPAGE="https://github.com/mauke/unibilium/"
9 SRC_URI="https://github.com/mauke/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
10
11 LICENSE="LGPL-3+ MIT"
12 SLOT="0/4"
13 KEYWORDS="amd64 arm x86"
14 IUSE="static-libs"
15
16 DEPEND="
17         dev-lang/perl
18         sys-devel/libtool"
19
20 RDEPEND=""
21
22 src_compile() {
23         append-flags -fPIC
24         emake PREFIX="${EPREFIX}/usr" LIBDIR="${EPREFIX}/usr/$(get_libdir)" all
25 }
26
27 src_install() {
28         emake PREFIX="${EPREFIX}/usr" LIBDIR="${EPREFIX}/usr/$(get_libdir)" DESTDIR="${D}" install
29         use static-libs || rm "${ED}"/usr/$(get_libdir)/lib${PN}.a || die
30         rm "${ED}"/usr/$(get_libdir)/lib${PN}.la || die
31 }