dev-libs/kuserfeedback: x86 stable wrt bug #721452
[gentoo.git] / dev-libs / udis86 / udis86-1.7.2.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 AUTOTOOLS_AUTORECONF=1
7 inherit autotools-multilib eutils
8
9 DESCRIPTION="Disassembler library for the x86/-64 architecture sets"
10 HOMEPAGE="http://udis86.sourceforge.net/"
11 SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
12
13 LICENSE="BSD"
14 SLOT="0"
15 KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
16 IUSE="test"
17 RESTRICT="!test? ( test )"
18
19 DEPEND="test? (
20                 amd64? ( dev-lang/yasm )
21                 x86? ( dev-lang/yasm )
22                 x86-fbsd? ( dev-lang/yasm )
23         )"
24 RDEPEND=""
25
26 PATCHES=(
27         "${FILESDIR}"/${P}-docdir.patch
28 )
29
30 src_configure() {
31         local myeconfargs=(
32                 --docdir="${EPREFIX}"/usr/share/doc/${PF}
33                 --disable-static
34                 --enable-shared
35                 --with-pic
36         )
37
38         autotools-multilib_src_configure
39 }