dev-libs/tvision: Fix gcc-6 compilation errors
[gentoo.git] / dev-libs / tvision / tvision-2.1.0_pre2-r3.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 inherit eutils multilib
5
6 DESCRIPTION="Text User Interface that implements the well known CUA widgets"
7 HOMEPAGE="http://tvision.sourceforge.net/"
8 SRC_URI="mirror://sourceforge/tvision/rhtvision_${PV/_pre/-}.tar.gz"
9
10 LICENSE="GPL-2"
11 SLOT="0"
12 KEYWORDS="amd64 ppc x86"
13 IUSE=""
14
15 S=${WORKDIR}/${PN}
16
17 src_unpack() {
18         unpack ${A}
19         cd "${S}"
20         epatch "${FILESDIR}"/${P}-gcc41.patch
21         epatch "${FILESDIR}"/${P}-outb.patch
22         epatch "${FILESDIR}"/${P}-underflow.patch
23         epatch "${FILESDIR}"/${P}-asneeded.patch
24         epatch "${FILESDIR}"/${P}-gcc44.patch
25         epatch "${FILESDIR}"/${P}-ldconfig.patch
26         epatch "${FILESDIR}"/${P}-flags.patch
27         epatch "${FILESDIR}"/${P}-gcc6.patch
28 }
29
30 src_compile() {
31         ./configure \
32                 --prefix=/usr \
33                 --fhs \
34                 || die
35         emake || die
36 }
37
38 src_install() {
39         einstall libdir="\$(prefix)/$(get_libdir)"|| die
40         dosym rhtvision /usr/include/tvision
41         dodoc readme.txt THANKS TODO
42         dohtml -r www-site
43 }