Use https by default
[gentoo.git] / dev-libs / tre / tre-0.8.0.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=3
6
7 PYTHON_DEPEND="2"
8 SUPPORT_PYTHON_ABIS="1"
9 RESTRICT_PYTHON_ABIS="3.* *-jython"
10
11 inherit distutils eutils
12
13 DESCRIPTION="Lightweight, robust, and efficient POSIX compliant regexp matching library"
14 HOMEPAGE="http://laurikari.net/tre/"
15 SRC_URI="http://laurikari.net/tre/${P}.tar.bz2"
16
17 LICENSE="BSD-2"
18 SLOT="0"
19 KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~x86-solaris"
20 IUSE="nls python static-libs"
21
22 RDEPEND="
23         !app-misc/glimpse
24         !app-text/agrep"
25 DEPEND="${RDEPEND}
26         virtual/pkgconfig
27         nls? ( sys-devel/gettext )"
28
29 DISTUTILS_SETUP_FILES=("python/setup.py")
30
31 pkg_setup() {
32         use python && python_pkg_setup
33 }
34
35 src_prepare() {
36         epatch \
37                 "${FILESDIR}"/${PV}-python.patch \
38                 "${FILESDIR}"/${PV}-pkgcfg.patch
39 }
40
41 src_configure() {
42         econf \
43                 --disable-dependency-tracking \
44                 --enable-agrep \
45                 --enable-system-abi \
46                 $(use_enable nls) \
47                 $(use_enable static-libs static)
48 }
49
50 src_compile() {
51         emake || die
52         use python && distutils_src_compile
53 }
54
55 src_test() {
56         if $(locale -a | grep -iq en_US.iso88591); then
57         emake -j1 \
58                 check || die
59         else
60                 ewarn "If you like to run the test,"
61                 ewarn "please make sure en_US.ISO-8859-1 is installed."
62                 die "en_US.ISO-8859-1 locale is missing"
63         fi
64 }
65
66 src_install() {
67         emake DESTDIR="${D}" install || die
68
69         local exe_ext=
70         [[ ${CHOST} = *mingw32* ]] && exe_ext=.exe
71         mv "${ED}"/usr/bin/agrep{,-tre}${exe_ext} || die
72
73         dodoc AUTHORS ChangeLog NEWS README THANKS TODO || die
74         dohtml doc/*.{css,html} || die
75         use python && distutils_src_install
76 }
77
78 pkg_postinst() {
79         echo
80         ewarn "app-misc/glimpse, app-text/agrep and this package all provide agrep."
81         ewarn "If this causes any unforeseen incompatibilities please file a bug"
82         ewarn "on https://bugs.gentoo.org."
83         echo
84
85         use python && distutils_pkg_postinst
86 }
87
88 pkg_postrm() {
89         use python && distutils_pkg_postrm
90 }