dev-libs/sord: bump serd dep, bug #601284
[gentoo.git] / dev-libs / sord / sord-0.16.0.ebuild
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=4
6
7 PYTHON_COMPAT=( python{2_7,3_4} )
8 PYTHON_REQ_USE='threads(+)'
9 inherit python-any-r1 waf-utils
10
11 DESCRIPTION="Library for storing RDF data in memory"
12 HOMEPAGE="http://drobilla.net/software/sord/"
13 SRC_URI="http://download.drobilla.net/${P}.tar.bz2"
14
15 LICENSE="ISC"
16 SLOT="0"
17 KEYWORDS="~amd64 ~ppc ~x86"
18 IUSE="doc static-libs test"
19
20 RDEPEND=">=dev-libs/serd-0.22.4"
21 DEPEND="${RDEPEND}
22         ${PYTHON_DEPS}
23         doc? ( app-doc/doxygen )
24         virtual/pkgconfig"
25
26 DOCS=( "AUTHORS" "NEWS" "README" )
27
28 src_prepare() {
29         sed -i -e 's/^.*run_ldconfig/#\0/' wscript || die
30 }
31
32 src_configure() {
33         waf-utils_src_configure \
34                 --docdir=/usr/share/doc/${PF} \
35                 $(use test && echo "--test") \
36                 $(use doc && echo "--docs") \
37                 $(use static-libs && echo "--static")
38 }
39
40 src_test() {
41         ./waf test || die
42 }