dev-libs/libgdata: remove old
[gentoo.git] / dev-libs / skalibs / skalibs-2.3.9.0.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 inherit multilib
7
8 DESCRIPTION="development files used for building software at skarnet.org: essentially general-purpose libraries"
9 HOMEPAGE="http://www.skarnet.org/software/skalibs/index.html"
10 SRC_URI="http://www.skarnet.org/software/${PN}/${P}.tar.gz"
11
12 LICENSE="ISC"
13 SLOT="0"
14 KEYWORDS="~amd64 ~x86"
15 IUSE="doc ipv6 static-libs"
16
17 DEPEND=">=sys-devel/make-3.81"
18 RDEPEND=""
19
20 src_prepare() {
21         # Remove QA warning about LDFLAGS addition
22         sed -i "s~tryldflag LDFLAGS_AUTO -Wl,--hash-style=both~:~" "${S}/configure" || die
23 }
24
25 src_configure() {
26         econf \
27                 $(use_enable ipv6) \
28                 $(use_enable static-libs static) \
29                 --dynlibdir=/$(get_libdir) \
30                 --libdir=/usr/$(get_libdir)/${PN} \
31                 --datadir=/etc \
32                 --sysdepdir=/usr/$(get_libdir)/${PN} \
33                 --enable-force-devr
34 }
35
36 src_install() {
37         default
38         dodir /etc/ld.so.conf.d/
39         echo "/$(get_libdir)/${PN}" > ${ED}/etc/ld.so.conf.d/10${PN}.conf || die
40
41         use doc && dohtml -r doc/*
42 }