*/*: Bump copyright on files touched this year
[gentoo.git] / dev-libs / rocm-hostcall / rocm-hostcall-2.7.0.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit cmake
7
8 if [[ ${PV} == *9999 ]] ; then
9         EGIT_REPO_URI="https://github.com/RadeonOpenCompute/ROCm-CompilerSupport/"
10         inherit git-r3
11         S="${WORKDIR}/${P}/lib/hostcall"
12 else
13         SRC_URI="https://github.com/RadeonOpenCompute/ROCm-CompilerSupport/archive/roc-${PV}.tar.gz -> ${P}.tar.gz"
14         S="${WORKDIR}/ROCm-CompilerSupport-roc-${PV}/lib/hostcall"
15         KEYWORDS="~amd64"
16 fi
17 PATCHES=(
18         "${FILESDIR}/${P}-install-correctly.patch"
19 )
20
21 DESCRIPTION="Radeon Open Compute hostcall API"
22 HOMEPAGE="https://github.com/RadeonOpenCompute/ROCm-CompilerSupport"
23 LICENSE="MIT"
24 SLOT="0/$(ver_cut 1-2)"
25
26 RDEPEND="dev-libs/rocr-runtime"
27 DEPEND="${RDEPEND}"