dev-libs/distorm64: Revert "drop old"
[gentoo.git] / dev-libs / rocm-device-libs / rocm-device-libs-9999.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit cmake
7
8 if [[ ${PV} == *9999 ]] ; then
9         EGIT_REPO_URI="https://github.com/RadeonOpenCompute/ROCm-Device-Libs/"
10         inherit git-r3
11         S="${WORKDIR}/${P}/src"
12 else
13         SRC_URI="https://github.com/RadeonOpenCompute/ROCm-Device-Libs/archive/roc-ocl-${PV}.tar.gz -> ${P}.tar.gz"
14         S="${WORKDIR}/ROCm-Device-Libs-roc-ocl-${PV}"
15         KEYWORDS="~amd64"
16 fi
17
18 DESCRIPTION="Radeon Open Compute Device Libraries"
19 HOMEPAGE="https://github.com/RadeonOpenCompute/ROCm-Device-Libs"
20
21 LICENSE="MIT"
22 SLOT="0/$(ver_cut 1-2)"
23
24 RDEPEND="dev-libs/rocr-runtime
25         sys-devel/llvm-roc:="
26 DEPEND="${RDEPEND}"
27
28 src_configure() {
29         local mycmakeargs=(
30                 -DLLVM_DIR="${EPREFIX}/usr/lib/llvm/roc/"
31         )
32         cmake_src_configure
33 }