dev-python/csv23: arm64 keyworded (bug #719700)
[gentoo.git] / dev-libs / qrosspython / qrosspython-0.3.2.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 PYTHON_COMPAT=( python2_7 )
7
8 inherit python-single-r1 cmake-utils
9
10 DESCRIPTION="Python scripting backend for Qross"
11 HOMEPAGE="https://github.com/0xd34df00d/Qross"
12 SRC_URI="https://github.com/0xd34df00d/Qross/archive/${PV}.tar.gz -> qrosscore-${PV}.tar.gz"
13
14 LICENSE="GPL-2"
15 SLOT="0"
16 KEYWORDS="~amd64 ~x86"
17 IUSE="debug"
18
19 RDEPEND="
20         ~dev-libs/qrosscore-${PV}
21         dev-python/sip
22         dev-qt/qtcore:5
23         dev-qt/qtgui:5
24         ${PYTHON_DEPS}
25 "
26 DEPEND="${RDEPEND}
27         dev-qt/qttest:5
28 "
29
30 REQUIRED_USE="${PYTHON_REQUIRED_USE}"
31
32 S="${WORKDIR}/Qross-${PV}"
33 CMAKE_USE_DIR="${S}/src/bindings/python/qrosspython"
34
35 mycmakeargs=( -DUSE_QT5=ON )