Merge remote-tracking branch 'github/pr/708'.
[gentoo.git] / dev-libs / qcustomplot / qcustomplot-1.3.2.ebuild
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=6
6
7 inherit qmake-utils
8
9 DESCRIPTION="Qt C++ widget for plotting and data visualization"
10 HOMEPAGE="http://www.qcustomplot.com/"
11 SRC_URI="
12         http://www.qcustomplot.com/release/${PV}/QCustomPlot-sharedlib.tar.gz -> ${PN}-sharedlib-${PV}.tar.gz
13         http://www.qcustomplot.com/release/${PV}/QCustomPlot-source.tar.gz -> ${PN}-source-${PV}.tar.gz"
14
15 SLOT="0"
16 LICENSE="GPL-3"
17 KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
18 IUSE="qt5"
19
20 RDEPEND="
21         !qt5? (
22                 dev-qt/qtcore:4
23                 dev-qt/qtgui:4
24         )
25         qt5? (
26                 dev-qt/qtcore:5
27                 dev-qt/qtgui:5
28                 dev-qt/qtprintsupport:5
29                 dev-qt/qtwidgets:5
30         )
31 "
32 DEPEND="${RDEPEND}"
33
34 S=${WORKDIR}/${PN}-source
35
36 src_prepare() {
37         default
38
39         sed \
40                 -e 's:../../::g' \
41                 -e '/CONFIG/s:shared.*:shared:g' \
42                 "${WORKDIR}"/${PN}-sharedlib/sharedlib-compilation/sharedlib-compilation.pro > ${PN}.pro || die
43 }
44
45 src_configure() {
46         use qt5 && eqmake5 || eqmake4
47 }
48
49 src_install() {
50         dolib.so lib${PN}*
51         doheader ${PN}.h
52         dodoc changelog.txt
53 }