dev-libs/pugixml: stable 1.9-r1 for ia64, bug #677472
[gentoo.git] / dev-libs / pugixml / pugixml-1.9-r1.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit cmake-utils
7
8 if [[ ${PV} == *9999 ]] ; then
9         EGIT_REPO_URI="https://github.com/zeux/${PN}.git"
10         inherit git-r3
11 else
12         SRC_URI="https://github.com/zeux/${PN}/releases/download/v${PV}/${P}.tar.gz"
13         KEYWORDS="~amd64 ~arm ~hppa ia64 ~ppc ~ppc64 sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
14 fi
15
16 DESCRIPTION="Light-weight, simple, and fast XML parser for C++ with XPath support"
17 HOMEPAGE="https://pugixml.org/ https://github.com/zeux/pugixml/"
18
19 LICENSE="MIT"
20 SLOT="0"
21
22 PATCHES=(
23         "${FILESDIR}/${P}-always-install-the-pkg-config-file.patch"
24         "${FILESDIR}/${P}-Use-CMAKE_INSTALL_LIBDIR-for-pugixml.pc.patch"
25         "${FILESDIR}/${P}-pkg-config-Use-CMake-GnuInstallDirs-FULL-vars.patch"
26 )
27
28 src_configure() {
29         local mycmakeargs=(
30                 -DBUILD_SHARED_LIBS=ON
31         )
32         cmake-utils_src_configure
33 }