ba22f30cfdb1287b636610b14ce7680528fe8a9c
[gentoo.git] / dev-libs / pugixml / pugixml-1.8.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=6
6 CMAKE_MAKEFILE_GENERATOR=emake
7
8 inherit cmake-utils
9
10 DESCRIPTION="Light-weight, simple, and fast XML parser for C++ with XPath support"
11 HOMEPAGE="http://pugixml.org/ https://github.com/zeux/pugixml/"
12 SRC_URI="https://github.com/zeux/${PN}/releases/download/v${PV}/${P}.tar.gz"
13
14 LICENSE="MIT"
15 SLOT="0"
16 KEYWORDS="amd64 ~arm ppc ~ppc64 x86 ~x86-fbsd ~amd64-linux ~x86-linux"
17
18 src_configure() {
19         local mycmakeargs=( -DBUILD_SHARED_LIBS=ON )
20         cmake-utils_src_configure
21 }