Merge remote-tracking branch 'github/pr/222'.
[gentoo.git] / dev-libs / pugixml / pugixml-1.7.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 inherit cmake-utils
8
9 DESCRIPTION="Light-weight, simple, and fast XML parser for C++ with XPath support"
10 HOMEPAGE="http://pugixml.org/ https://github.com/zeux/pugixml/"
11 SRC_URI="https://github.com/zeux/${PN}/releases/download/v${PV}/${P}.tar.gz"
12
13 LICENSE="MIT"
14 SLOT="0"
15 KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
16
17 S=${WORKDIR}/${P}/scripts
18
19 src_configure() {
20         local mycmakeargs=( -DBUILD_SHARED_LIBS=ON )
21         cmake-utils_src_configure
22 }