*/*: reassign crypto@ packages
[gentoo.git] / dev-libs / pkcs11-helper / pkcs11-helper-1.25.1.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 DESCRIPTION="PKCS#11 helper library"
7 HOMEPAGE="https://github.com/OpenSC/pkcs11-helper"
8 SRC_URI="https://github.com/OpenSC/${PN}/releases/download/${P}/${P}.tar.bz2"
9
10 LICENSE="|| ( BSD GPL-2 )"
11 SLOT="0"
12 KEYWORDS="alpha amd64 arm arm64 ~hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh ~sparc x86"
13 IUSE="bindist doc gnutls libressl nss static-libs"
14
15 RDEPEND="
16         !libressl? ( >=dev-libs/openssl-0.9.7:0=[bindist=] )
17         libressl? ( dev-libs/libressl )
18         gnutls? ( >=net-libs/gnutls-1.4.4 )
19         nss? ( dev-libs/nss )"
20 DEPEND="${RDEPEND}"
21 BDEPEND="virtual/pkgconfig
22         doc? ( >=app-doc/doxygen-1.4.7 )"
23
24 PATCHES=(
25         "${FILESDIR}/${P}-build.patch"
26 )
27
28 src_configure() {
29         econf \
30                 --disable-crypto-engine-polarssl \
31                 --disable-crypto-engine-mbedtls \
32                 $(use_enable doc) \
33                 $(use_enable gnutls crypto-engine-gnutls) \
34                 $(use_enable nss crypto-engine-nss) \
35                 $(use_enable static-libs static)
36 }
37
38 src_install() {
39         default
40         find "${D}" -name '*.la' -delete || die
41 }