dev-qt/qtx11extras: stable 5.14.2 for ppc, bug #719732
[gentoo.git] / dev-libs / pegtl / pegtl-1.3.1-r1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit toolchain-funcs
7
8 DESCRIPTION="header-only library for creating parsers according to Parsing Expression Grammar"
9 HOMEPAGE="https://github.com/ColinH/PEGTL"
10 SRC_URI="https://github.com/ColinH/PEGTL/archive/${PV}.tar.gz -> ${P}.tar.gz"
11
12 LICENSE="MIT"
13 SLOT="0"
14 KEYWORDS="~amd64 ~x86"
15 IUSE="test"
16 RESTRICT="!test? ( test )"
17
18 DEPEND=""
19 RDEPEND="${DEPEND}"
20
21 S="${WORKDIR}/PEGTL-${PV}"
22
23 src_compile() {
24         :
25 }
26
27 src_test() {
28         emake CXX="$(tc-getCXX)" PEGTL_CXXFLAGS="${CXXFLAGS}"
29 }
30
31 src_install() {
32         dodoc README.md
33         insinto /usr/include
34         doins -r pegtl pegtl.hh
35 }