dev-libs/libxml2: arm64 stable (bug #701020)
[gentoo.git] / dev-libs / pcc-libs / pcc-libs-9999.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 inherit eutils versionator
7
8 DESCRIPTION="pcc compiler support libs"
9 HOMEPAGE="http://pcc.ludd.ltu.se"
10
11 if [[ ${PV} = 9999 ]]; then
12         inherit cvs
13         ECVS_SERVER="pcc.ludd.ltu.se:/cvsroot"
14         ECVS_MODULE="${PN}"
15         S="${WORKDIR}/${PN}"
16         KEYWORDS=""
17 else
18         SRC_URI="ftp://pcc.ludd.ltu.se/pub/pcc-releases/${P}.tgz"
19         KEYWORDS="~amd64 ~x86"
20 fi
21 LICENSE="BSD"
22 SLOT="0"
23
24 IUSE=""
25 DEPEND=""
26 RDEPEND="${DEPEND}"
27
28 src_compile() {
29         # not parallel-safe yet
30         emake -j1
31 }
32
33 src_install() {
34         emake DESTDIR="${D}" install
35 }