net-misc/dhcpcd: amd64 stable wrt bug #682318
[gentoo.git] / dev-libs / opensc / opensc-0.16.0.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit ltprune
7
8 DESCRIPTION="Libraries and applications to access smartcards"
9 HOMEPAGE="https://github.com/OpenSC/OpenSC/wiki"
10 SRC_URI="https://github.com/OpenSC/OpenSC/releases/download/${PV}/${P}.tar.gz"
11
12 LICENSE="LGPL-2.1"
13 SLOT="0"
14 KEYWORDS="alpha amd64 arm hppa ia64 ~m68k ppc ppc64 ~s390 ~sh sparc x86"
15 IUSE="doc +pcsc-lite secure-messaging openct ctapi readline libressl ssl zlib"
16
17 RDEPEND="zlib? ( sys-libs/zlib )
18         readline? ( sys-libs/readline:0= )
19         ssl? (
20                 !libressl? ( dev-libs/openssl:0= )
21                 libressl? ( dev-libs/libressl:0= )
22         )
23         openct? ( >=dev-libs/openct-0.5.0 )
24         pcsc-lite? ( >=sys-apps/pcsc-lite-1.3.0 )"
25 DEPEND="${RDEPEND}
26         virtual/pkgconfig
27         app-text/docbook-xsl-stylesheets
28         dev-libs/libxslt"
29
30 REQUIRED_USE="
31         pcsc-lite? ( !openct !ctapi )
32         openct? ( !pcsc-lite !ctapi )
33         ctapi? ( !pcsc-lite !openct )
34         || ( pcsc-lite openct ctapi )"
35
36 src_configure() {
37         econf \
38                 --docdir="/usr/share/doc/${PF}" \
39                 --htmldir='$(docdir)/html' \
40                 --disable-static \
41                 $(use_enable doc) \
42                 $(use_enable openct) \
43                 $(use_enable readline) \
44                 $(use_enable zlib) \
45                 $(use_enable secure-messaging sm) \
46                 $(use_enable ssl openssl) \
47                 $(use_enable pcsc-lite pcsc) \
48                 $(use_enable openct) \
49                 $(use_enable ctapi)
50 }
51
52 src_install() {
53         default
54         prune_libtool_files --all
55 }