Merge remote-tracking branch 'github/pr/1633', bug 527306 by Ettore Di Giacinto
[gentoo.git] / dev-libs / opensc / opensc-0.14.0.ebuild
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 inherit eutils
8
9 DESCRIPTION="Libraries and applications to access smartcards"
10 HOMEPAGE="https://github.com/OpenSC/OpenSC/wiki"
11 SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
12
13 LICENSE="LGPL-2.1"
14 SLOT="0"
15 KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
16 IUSE="doc +pcsc-lite secure-messaging openct ctapi readline libressl ssl zlib"
17
18 RDEPEND="zlib? ( sys-libs/zlib )
19         readline? ( sys-libs/readline:0= )
20         ssl? (
21                 !libressl? ( dev-libs/openssl:0= )
22                 libressl? ( dev-libs/libressl:0= )
23         )
24         openct? ( >=dev-libs/openct-0.5.0 )
25         pcsc-lite? ( >=sys-apps/pcsc-lite-1.3.0 )"
26 DEPEND="${RDEPEND}
27         virtual/pkgconfig
28         app-text/docbook-xsl-stylesheets
29         dev-libs/libxslt"
30
31 REQUIRED_USE="
32         pcsc-lite? ( !openct !ctapi )
33         openct? ( !pcsc-lite !ctapi )
34         ctapi? ( !pcsc-lite !openct )
35         || ( pcsc-lite openct ctapi )"
36
37 src_configure() {
38         econf \
39                 --docdir="/usr/share/doc/${PF}" \
40                 --htmldir='$(docdir)/html' \
41                 --disable-static \
42                 $(use_enable doc) \
43                 $(use_enable openct) \
44                 $(use_enable readline) \
45                 $(use_enable zlib) \
46                 $(use_enable secure-messaging sm) \
47                 $(use_enable ssl openssl) \
48                 $(use_enable pcsc-lite pcsc) \
49                 $(use_enable openct) \
50                 $(use_enable ctapi)
51 }
52
53 src_install() {
54         default
55         find "${ED}"/usr -name '*.la' -delete
56 }