dev-libs/oniguruma: Version bump (6.8.2).
[gentoo.git] / dev-libs / oniguruma / oniguruma-6.8.1.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI="6"
5
6 inherit multilib-minimal
7
8 MY_P="onig-${PV}"
9
10 DESCRIPTION="Regular expression library for different character encodings"
11 HOMEPAGE="https://github.com/kkos/oniguruma"
12 SRC_URI="https://github.com/kkos/${PN}/releases/download/v${PV}/${MY_P}.tar.gz"
13
14 LICENSE="BSD-2"
15 SLOT="0/5"
16 KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
17 IUSE="crnl-as-line-terminator static-libs"
18
19 S="${WORKDIR}/${MY_P}"
20
21 DOCS=(AUTHORS HISTORY README{,_japanese} doc/{API,CALLOUTS.BUILTIN,FAQ,RE}{,.ja} doc/UNICODE_PROPERTIES)
22
23 multilib_src_configure() {
24         ECONF_SOURCE="${S}" econf \
25                 $(use_enable crnl-as-line-terminator) \
26                 $(use_enable static-libs static)
27 }
28
29 multilib_src_install_all() {
30         einstalldocs
31         find "${D}" -name "*.la" -delete || die
32 }