dev-libs/nsync: new ebuild by me v1.20.1
[gentoo.git] / dev-libs / nsync / nsync-1.20.1.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit cmake-multilib
7
8 DESCRIPTION="A C library that exports various synchronization primitives, such as mutexes"
9 HOMEPAGE="https://github.com/google/nsync"
10 SRC_URI="https://github.com/google/nsync/archive/${PV}.tar.gz -> ${P}.tar.gz"
11
12 LICENSE="Apache-2.0"
13 SLOT="0"
14 KEYWORDS="~amd64 ~x86"
15 IUSE="test"
16
17 DOCS=( README )
18
19 multilib_src_configure() {
20         local mycmakeargs=(
21                 -DBUILD_SHARED_LIBS=ON
22                 -DNSYNC_ENABLE_TESTS=$(usex test)
23         )
24
25         cmake-utils_src_configure
26 }