dev-libs/icu-layoutex: sparc stable wrt bug #716822
[gentoo.git] / dev-libs / nsgenbind / nsgenbind-0.6-r1.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit toolchain-funcs
7
8 DESCRIPTION="generate javascript to dom bindings from w3c webidl files"
9 HOMEPAGE="http://www.netsurf-browser.org/"
10 SRC_URI="https://download.netsurf-browser.org/libs/releases/${P}-src.tar.gz"
11
12 LICENSE="MIT"
13 SLOT="0/${PV}"
14 KEYWORDS="~amd64 ~arm ~ppc ~ppc64"
15 IUSE=""
16
17 DEPEND="
18         dev-util/netsurf-buildsystem
19         virtual/yacc"
20
21 _emake() {
22         source /usr/share/netsurf-buildsystem/gentoo-helpers.sh
23         netsurf_define_makeconf
24         emake "${NETSURF_MAKECONF[@]}" COMPONENT_TYPE=binary $@
25 }
26
27 src_compile() {
28         _emake
29 }
30
31 src_install() {
32         _emake DESTDIR="${ED}" install
33 }