dev-libs/nanomsg: remove old versions
[gentoo.git] / dev-libs / nanomsg / nanomsg-0.8.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 AUTOTOOLS_AUTORECONF=1
8 inherit autotools-multilib
9
10 DESCRIPTION="High-performance messaging interface for distributed applications"
11 HOMEPAGE="http://nanomsg.org/"
12 SRC_URI="https://github.com/nanomsg/nanomsg/releases/download/${PV}-beta/${P}-beta.tar.gz"
13
14 LICENSE="MIT"
15 SLOT="0/0.2.2"
16 KEYWORDS="~amd64 ~arm ~mips ~ppc ~ppc64 ~s390 ~x86"
17 IUSE="doc static-libs"
18
19 DEPEND="doc? (
20                 app-text/asciidoc
21                 app-text/xmlto
22         )"
23 RDEPEND=""
24
25 S="${WORKDIR}/${P}-beta"
26
27 src_prepare() {
28         sed -i -e 's/doc_DATA/html_DATA/' Makefile.am || die
29
30         autotools-multilib_src_prepare
31 }
32
33 multilib_src_configure() {
34         local myeconfargs=(
35                 --htmldir "/usr/share/doc/${PF}/html"
36         )
37         if multilib_is_native_abi; then
38                 myeconfargs+=(
39                         $(use_enable doc)
40                 )
41         else
42                 myeconfargs+=(
43                         --disable-doc
44                         --disable-nanocat
45                         --disable-symlinks
46                 )
47         fi
48         autotools-utils_src_configure
49 }