dev-libs/leatherman: 1.12.0 stable amd64/x86 with cleanup
[gentoo.git] / dev-libs / mimetic / mimetic-0.9.8.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit autotools
7
8 DESCRIPTION="C++ MIME library designed to be easy to use and integrate, fast and efficient."
9 HOMEPAGE="http://www.codesink.org/mimetic_mime_library.html"
10 SRC_URI="http://www.codesink.org/download/${P}.tar.gz"
11
12 LICENSE="MIT"
13 SLOT="0"
14 KEYWORDS="amd64 ~ppc64 x86"
15 IUSE="doc examples"
16
17 DEPEND="doc? ( app-doc/doxygen )"
18
19 PATCHES=( "${FILESDIR}/signed-char.patch" )
20
21 src_prepare() {
22         default
23
24         sed -i -e "s|../doxygen.css|doxygen.css|" doc/header.html || die
25
26         mv configure.in configure.ac || die
27         eautoreconf
28 }
29
30 src_configure() {
31         econf --disable-static
32 }
33
34 src_compile() {
35         default
36         use doc && emake -C doc docs
37 }
38
39 src_install() {
40         default
41
42         use doc && dodoc -r doc/html/
43
44         if use examples ; then
45                 docinto examples
46                 dodoc examples/{README,TODO,test.msg,*.cxx,*.h}
47         fi
48
49         rm "${D}"/usr/$(get_libdir)/libmimetic.la || die
50 }