dev-qt/qttest: stable 5.14.2 for ppc, bug #719732
[gentoo.git] / dev-libs / maloc / maloc-1.5-r1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 AUTOTOOLS_AUTORECONF=yes
7
8 inherit autotools-utils
9
10 DESCRIPTION="Minimal Abstraction Layer for Object-oriented C/C++ programs"
11 HOMEPAGE="http://www.fetk.org/codes/maloc/index.html"
12 SRC_URI="http://www.fetk.org/codes/download/${P}.tar.gz"
13
14 SLOT="0"
15 LICENSE="GPL-2"
16 IUSE="doc mpi static-libs"
17 KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux"
18
19 RDEPEND="
20         sys-libs/readline:0=
21         mpi? ( virtual/mpi )"
22 DEPEND="${RDEPEND}
23         doc? (
24                 media-gfx/graphviz
25                 app-doc/doxygen
26                 )"
27
28 S="${WORKDIR}/${PN}"
29
30 PATCHES=(
31         "${FILESDIR}"/1.4-mpi.patch
32         "${FILESDIR}"/1.4-asneeded.patch
33         "${FILESDIR}"/1.4-doc.patch
34         )
35
36 src_prepare() {
37         echo 'VPUBLIC int Vio_getc(Vio *thee){  ASC *asc; asc = thee->axdr; return asc->buf[asc->pos++];  }' >> src/vsys/vio.c || die
38         autotools-utils_src_prepare
39 }
40
41 src_configure() {
42         local myeconfargs
43         use mpi && export CC="mpicc"
44         use doc || myeconfargs+=( --with-doxygen= --with-dot= )
45
46         myeconfargs+=(
47                 --docdir="${EPREFIX}"/usr/share/doc/${PF}
48                 $(use_enable mpi)
49                 --disable-triplet
50                 )
51         autotools-utils_src_configure
52 }
53
54 src_install() {
55         autotools-utils_src_install
56
57         # install doc
58         dohtml doc/index.html
59 }