dev-libs/libax25: Drop old
[gentoo.git] / dev-libs / m17n-lib / m17n-lib-1.8.0.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI="6"
5
6 inherit autotools
7
8 DESCRIPTION="Multilingual Library for Unix/Linux"
9 HOMEPAGE="https://savannah.nongnu.org/projects/m17n https://git.savannah.nongnu.org/cgit/m17n/m17n-lib.git"
10 SRC_URI="mirror://nongnu/m17n/${P}.tar.gz"
11
12 LICENSE="LGPL-2.1"
13 SLOT="0"
14 KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
15 IUSE="X anthy athena bidi fontconfig gd libotf libxml2 spell xft"
16
17 RDEPEND="~dev-db/m17n-db-${PV}
18         X? (
19                 x11-libs/libX11
20                 athena? ( x11-libs/libXaw )
21                 bidi? ( dev-libs/fribidi )
22                 fontconfig? ( media-libs/fontconfig )
23                 gd? ( media-libs/gd[png] )
24                 libotf? ( dev-libs/libotf )
25                 xft? (
26                         media-libs/freetype
27                         x11-libs/libXft
28                 )
29         )
30         anthy? ( app-i18n/anthy )
31         libxml2? ( dev-libs/libxml2 )
32         spell? ( app-text/aspell )"
33 DEPEND="${RDEPEND}
34         virtual/pkgconfig"
35
36 PATCHES=(
37         "${FILESDIR}"/${PN}-configure.patch
38         "${FILESDIR}"/${PN}-freetype.patch
39         "${FILESDIR}"/${PN}-ftconfig.patch
40         "${FILESDIR}"/${PN}-ispell.patch
41         "${FILESDIR}"/${PN}-parallel-make.patch
42         "${FILESDIR}"/${PN}-pkg-config.patch
43 )
44
45 src_prepare() {
46         default
47
48         eautoreconf
49         # workaround for parallel install
50         sed -i "/^install-module/s/:/: install-libLTLIBRARIES/" src/Makefile.in
51 }
52
53 src_configure() {
54         local myconf=(
55                 $(use_with anthy)
56                 $(use_with libxml2)
57                 $(use_with spell ispell)
58         )
59         if use X; then
60                 myconf+=(
61                         $(use_with athena)
62                         $(use_with bidi fribidi)
63                         $(use_with fontconfig)
64                         $(use_with xft freetype)
65                         $(use_with gd)
66                         --with-gui
67                         $(use_with libotf)
68                         --with-x
69                         $(use_with xft)
70                 )
71         else
72                 myconf+=(
73                         --without-athena
74                         --without-fontconfig
75                         --without-freetype
76                         --without-fribidi
77                         --without-gd
78                         --without-gui
79                         --without-libotf
80                         --without-x
81                         --without-xft
82                 )
83         fi
84
85         econf "${myconf[@]}"
86 }