dev-qt/qttest: stable 5.14.2 for ppc, bug #719732
[gentoo.git] / dev-libs / log4sh / log4sh-1.4.2.ebuild
1 # Copyright 1999-2013 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 inherit eutils
7
8 DESCRIPTION="A flexible logging framework for shell scripts"
9 HOMEPAGE="https://sourceforge.net/projects/log4sh"
10 SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
11
12 LICENSE="LGPL-2.1"
13 SLOT="0"
14 KEYWORDS="amd64 ~arm ~ppc x86"
15 IUSE="examples"
16
17 RDEPEND="app-shells/bash"
18
19 src_compile() {
20         emake build
21 }
22
23 src_test() {
24         # testsuite needs USER variable
25         export USER="$(whoami)"
26         make test || die "make test failed"
27 }
28
29 src_install() {
30         insinto /usr/lib/log4sh
31         doins build/log4sh
32
33         dodoc doc/*.txt
34         dohtml doc/*.{html,css}
35
36         if use examples; then
37                 docinto examples
38                 docompress -x /usr/share/doc/${PF}/examples
39                 dodoc src/examples/*
40         fi
41 }
42
43 pkg_postinst() {
44         elog "To use log4sh, have your script source /usr/lib/log4sh/log4sh"
45         elog "If you want to use remote logging, you should install package,"
46         elog "that provides netcat binary (for example - net-analyzer/netcat)"
47 }