dev-libs/libzip: D -> ED
[gentoo.git] / dev-libs / libzip / libzip-1.2.0.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit autotools
7
8 DESCRIPTION="Library for manipulating zip archives"
9 HOMEPAGE="http://www.nih.at/libzip/"
10 SRC_URI="http://www.nih.at/libzip/${P}.tar.xz"
11
12 LICENSE="BSD"
13 SLOT="0/5"
14 KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~x86-macos"
15 IUSE="static-libs"
16
17 RDEPEND="
18         sys-libs/zlib
19         elibc_musl? ( sys-libs/fts-standalone )
20 "
21 DEPEND="${RDEPEND}"
22
23 DOCS=( AUTHORS NEWS.md API-CHANGES THANKS )
24
25 PATCHES=(
26         "${FILESDIR}/${P}-headers.patch"
27         "${FILESDIR}/${P}-fts.patch"
28 )
29
30 src_prepare() {
31         default
32         eautoreconf
33 }
34
35 src_install() {
36         default
37         use static-libs || rm "${ED%/}"/usr/lib64/libzip.a || die
38         find "${D}" -name '*.la' -delete || die
39 }