*/*: Drop stable ia64 keywords
[gentoo.git] / dev-libs / libyaml / libyaml-0.2.2.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit autotools libtool
7
8 DESCRIPTION="YAML 1.1 parser and emitter written in C"
9 HOMEPAGE="https://github.com/yaml/libyaml"
10 SRC_URI="https://github.com/yaml/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
11
12 LICENSE="MIT"
13 SLOT="0"
14 KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 m68k ~mips ppc ppc64 ~riscv s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
15 IUSE="doc static-libs test"
16 RESTRICT="!test? ( test )"
17
18 DEPEND="doc? ( app-doc/doxygen )"
19
20 src_prepare() {
21         default
22
23         # conditionally remove tests
24         if ! use test; then
25                 sed -i -e 's: tests::g' Makefile* || die
26         fi
27
28         elibtoolize  # for FreeMiNT
29         eautoreconf
30 }
31
32 src_configure() {
33         econf $(use_enable static-libs static)
34 }
35
36 src_compile() {
37         emake
38         use doc && emake html
39 }
40
41 src_install() {
42         use doc && HTML_DOCS=( doc/html/. )
43         default
44         find "${D}" -name '*.la' -delete || die
45 }