dev-libs/libxmlb: Bump to version 0.1.9
[gentoo.git] / dev-libs / libxmlb / libxmlb-0.1.7.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit meson
7
8 DESCRIPTION="Library to help create and query binary XML blobs"
9 HOMEPAGE="https://github.com/hughsie/libxmlb"
10 SRC_URI="https://github.com/hughsie/libxmlb/archive/${PV}.tar.gz -> ${P}.tar.gz"
11 LICENSE="LGPL-2.1+"
12 SLOT="0"
13
14 KEYWORDS="~amd64 ~arm ~arm64 ~x86"
15 IUSE="doc introspection stemmer test"
16
17 RDEPEND="
18         dev-libs/glib:2
19         sys-apps/util-linux
20         stemmer? ( dev-libs/snowball-stemmer )
21 "
22
23 DEPEND="
24         ${RDEPEND}
25         doc? ( dev-util/gtk-doc )
26         introspection? ( dev-libs/gobject-introspection )
27 "
28
29 BDEPEND="
30         >=dev-util/meson-0.47.0
31         virtual/pkgconfig
32 "
33
34 src_configure() {
35         local emesonargs=(
36                 -Dgtkdoc="$(usex doc true false)"
37                 -Dintrospection="$(usex introspection true false)"
38                 -Dstemmer="$(usex stemmer true false)"
39                 -Dtests="$(usex test true false)"
40         )
41         meson_src_configure
42 }