dev-libs/leatherman: 1.12.0 stable amd64/x86 with cleanup
[gentoo.git] / dev-libs / libxls / libxls-1.5.2-r1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit eutils
7
8 DESCRIPTION="A library which can read Excel (xls) files"
9 HOMEPAGE="https://github.com/libxls/libxls"
10 SRC_URI="https://github.com/libxls/libxls/releases/download/v${PV}/${P}.tar.gz"
11
12 LICENSE="BSD-2"
13 SLOT="0/1" # libxlsreader.so.1
14 KEYWORDS="amd64 x86"
15 IUSE=""
16
17 RDEPEND=""
18 DEPEND=""
19 BDEPEND="
20         app-arch/unzip
21         virtual/pkgconfig
22 "
23
24 RESTRICT=test # test driver is missing
25
26 PATCHES=(
27         "${FILESDIR}"/${PN}-1.4.0-asprintf.patch
28 )
29
30 src_configure() {
31         econf \
32                 --disable-static
33 }
34
35 src_install() {
36         default
37
38         find "${D}" -name '*.la' -type f -delete || die
39 }