dev-libs/re2: amd64 stable wrt bug #723954
[gentoo.git] / dev-libs / libx86emu / libx86emu-1.1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit rpm toolchain-funcs
7
8 DESCRIPTION="A library for emulating x86"
9 HOMEPAGE="https://www.opensuse.org/"
10 SRC_URI="https://download.opensuse.org/source/factory/repo/oss/suse/src/${P}-9.8.src.rpm"
11
12 LICENSE="HPND"
13 SLOT="0"
14 KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
15
16 PATCHES=(
17         "${FILESDIR}"/${PN}-1.1-fix-makefile.patch
18         "${FILESDIR}"/${PN}-1.1-gcc10-fno-common.patch
19 )
20
21 src_configure() {
22         tc-export CC
23 }
24
25 src_install() {
26         emake DESTDIR="${ED}" LIBDIR="/usr/$(get_libdir)" install
27         dodoc Changelog README
28 }