dev-libs/leatherman: 1.12.0 stable amd64/x86 with cleanup
[gentoo.git] / dev-libs / libwapcaplet / libwapcaplet-0.4.1-r1.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit toolchain-funcs
7
8 DESCRIPTION="string internment library, written in C"
9 HOMEPAGE="http://www.netsurf-browser.org/projects/libwapcaplet/"
10 SRC_URI="https://download.netsurf-browser.org/libs/releases/${P}-src.tar.gz"
11
12 LICENSE="MIT"
13 SLOT="0/${PV}"
14 KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~m68k-mint"
15 IUSE="test"
16 RESTRICT="!test? ( test )"
17
18 DEPEND="
19         >=dev-util/netsurf-buildsystem-1.7-r1
20         test? ( >=dev-libs/check-0.9.11 )"
21
22 PATCHES=(
23         # bug 664288
24         "${FILESDIR}/${PN}-0.4.1-makefile.patch"
25 )
26
27 _emake() {
28         source /usr/share/netsurf-buildsystem/gentoo-helpers.sh
29         netsurf_define_makeconf
30         emake "${NETSURF_MAKECONF[@]}" COMPONENT_TYPE=lib-shared $@
31 }
32
33 src_compile() {
34         _emake
35 }
36
37 src_test() {
38         _emake test
39 }
40
41 src_install() {
42         _emake DESTDIR="${ED}" install
43 }