dev-libs/libvterm: rename ebuild.
[gentoo.git] / dev-libs / libvterm / libvterm-0.0_pre20171004.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5 inherit eutils flag-o-matic multilib
6
7 DESCRIPTION="An abstract library implementation of a VT220/xterm/ECMA-48 terminal emulator"
8 HOMEPAGE="http://www.leonerd.org.uk/code/libvterm/"
9 SRC_URI="https://dev.gentoo.org/~tranquility/distfiles/${P}.tar.xz"
10
11 LICENSE="MIT"
12 SLOT="0"
13 KEYWORDS="~amd64 ~x86"
14
15 DEPEND="
16         sys-devel/libtool
17         virtual/pkgconfig"
18
19 RDEPEND="!dev-libs/libvterm-neovim"
20
21 src_compile() {
22         append-cflags -fPIC
23         emake PREFIX="${EPREFIX}/usr" LIBDIR="${EPREFIX}/usr/$(get_libdir)"
24 }
25
26 src_install() {
27         emake \
28                 PREFIX="${EPREFIX}/usr" \
29                 LIBDIR="${EPREFIX}/usr/$(get_libdir)" \
30                 DESTDIR="${D}" install
31         prune_libtool_files
32
33         dodoc doc/*
34 }