dev-python/csv23: arm64 keyworded (bug #719700)
[gentoo.git] / dev-libs / libvarlink / libvarlink-18.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit meson
7
8 DESCRIPTION="C implementation of the Varlink protocol and command line tool"
9 HOMEPAGE="https://github.com/varlink/libvarlink"
10 SRC_URI="https://github.com/varlink/libvarlink/archive/${PV}.tar.gz -> ${P}.tar.gz"
11 LICENSE="Apache-2.0"
12 SLOT="0"
13
14 KEYWORDS="~amd64"
15 IUSE="test"
16 RESTRICT="!test? ( test )"
17 RDEPEND=""
18 DEPEND="${RDEPEND}"
19 BDEPEND="
20         >=dev-util/meson-0.47.0
21         virtual/pkgconfig
22 "
23
24 src_configure() {
25         local emesonargs=(
26                 -Dtests="$(usex test true false)"
27         )
28         meson_src_configure
29 }