dev-libs/libunistring: stable 0.9.10 for ia64, bug #674644
[gentoo.git] / dev-libs / libunistring / libunistring-0.9.8.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit eutils multilib-minimal libtool
7
8 DESCRIPTION="Library for manipulating Unicode and C strings according to Unicode standard"
9 HOMEPAGE="https://www.gnu.org/software/libunistring/"
10 SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
11
12 LICENSE="LGPL-3 GPL-3"
13 SLOT="0/2"
14 KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x64-cygwin ~amd64-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
15 IUSE="doc static-libs"
16
17 PATCHES=(
18         "${FILESDIR}"/${PN}-nodocs.patch
19 )
20
21 src_prepare() {
22         default
23         elibtoolize  # for Solaris shared libraries
24 }
25
26 multilib_src_configure() {
27         ECONF_SOURCE="${S}" \
28         econf $(use_enable static-libs static)
29 }
30
31 multilib_src_install() {
32         default
33
34         prune_libtool_files
35 }
36
37 multilib_src_install_all() {
38         default
39
40         if use doc; then
41                 dohtml doc/*.html
42                 doinfo doc/*.info
43         fi
44 }