dev-libs/libunistring: Version 0.9.9.
[gentoo.git] / dev-libs / libunistring / libunistring-0.9.5.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI="5"
5
6 inherit eutils
7
8 DESCRIPTION="Library for manipulating Unicode and C strings according to Unicode standard"
9 HOMEPAGE="https://www.gnu.org/software/libunistring/"
10 SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
11
12 LICENSE="LGPL-3 GPL-3"
13 SLOT="0/2"
14 KEYWORDS="amd64 arm x86 ~amd64-linux"
15 IUSE="doc static-libs"
16
17 src_prepare() {
18         epatch "${FILESDIR}"/${PN}-nodocs.patch
19 }
20
21 src_configure() {
22         econf $(use_enable static-libs static)
23 }
24
25 src_install() {
26         dodoc AUTHORS README ChangeLog || die "dodoc failed"
27         if use doc; then
28                 dohtml doc/*.html || die "dohtml failed"
29                 doinfo doc/*.info || die "doinfo failed"
30         fi
31
32         emake DESTDIR="${D}" install || die "Install failed"
33
34         prune_libtool_files
35 }