dev-libs/libugpio: x86 stable (bug #682740)
[gentoo.git] / dev-libs / libugpio / libugpio-0.0.6.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit linux-info
7
8 DESCRIPTION="Lib for the use of linux kernel's sysfs gpio interface from C programs"
9 HOMEPAGE="https://github.com/mhei/libugpio"
10 SRC_URI="https://github.com/mhei/${PN}/releases/download/v${PV}/${P}.tar.bz2"
11
12 LICENSE="GPL-3+ LGPL-2.1+"
13 SLOT="0"
14 KEYWORDS="amd64 ppc ppc64 x86"
15
16 CONFIG_CHECK="~CONFIG_GPIO_SYSFS"
17
18 src_configure() {
19         local myeconfargs=(
20                 --disable-static
21         )
22
23         econf "${myeconfargs[@]}"
24 }
25
26 src_install() {
27         default
28
29         find "${D}" -name '*.la' -delete || die
30 }