dev-libs/libnfc: bump
[gentoo.git] / dev-libs / libudfread / libudfread-9999.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit autotools multilib-minimal
7
8 if [[ ${PV} == *9999 ]] ; then
9         EGIT_REPO_URI="https://code.videolan.org/videolan/${PN}.git"
10         inherit git-r3
11 else
12         SRC_URI="https://code.videolan.org/videolan/libudfread/-/archive/${PV}/${P}.tar.gz"
13         KEYWORDS="~amd64"
14 fi
15
16 DESCRIPTION="Library for reading UDF from raw devices and image files"
17 HOMEPAGE="https://code.videolan.org/videolan/libudfread/"
18
19 LICENSE="LGPL-2.1+"
20 SLOT="0"
21 IUSE=""
22
23 src_prepare() {
24         default
25         eautoreconf
26 }
27
28 multilib_src_configure() {
29         ECONF_SOURCE="${S}" econf
30 }