dev-libs/libtermkey: version update to 0.18
[gentoo.git] / dev-libs / libtermkey / libtermkey-0.17.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6 inherit eutils flag-o-matic multilib
7
8 DESCRIPTION="Library for easy processing of keyboard entry from terminal-based programs"
9 HOMEPAGE="http://www.leonerd.org.uk/code/libtermkey/"
10 SRC_URI="http://www.leonerd.org.uk/code/${PN}/${P}.tar.gz"
11
12 LICENSE="MIT"
13 SLOT="0"
14 KEYWORDS="~amd64 ~x86"
15 IUSE="demos"
16
17 RDEPEND="dev-libs/unibilium:="
18 DEPEND="${RDEPEND}
19         sys-devel/libtool
20         virtual/pkgconfig
21         demos? ( dev-libs/glib:2 )"
22
23 src_prepare() {
24         if ! use demos; then
25                 sed -e '/^all:/s:$(DEMOS)::' -i Makefile || die
26         fi
27 }
28
29 src_compile() {
30         append-flags -fPIC -fPIE
31         emake PREFIX="${EPREFIX}/usr" LIBDIR="${EPREFIX}/usr/$(get_libdir)" all
32 }
33
34 src_install() {
35         emake PREFIX="${EPREFIX}/usr" LIBDIR="${EPREFIX}/usr/$(get_libdir)" \
36                 DESTDIR="${D}" install
37         prune_libtool_files
38 }