dev-libs/liborcus: Fix bashisms in configure.ac, --disable-static
[gentoo.git] / dev-libs / libtecla / libtecla-1.6.3.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit autotools flag-o-matic
7
8 DESCRIPTION="Tecla command-line editing library"
9 HOMEPAGE="http://www.astro.caltech.edu/~mcs/tecla/"
10 SRC_URI="http://www.astro.caltech.edu/~mcs/tecla/${P}.tar.gz"
11
12 LICENSE="icu"
13 SLOT="0"
14 KEYWORDS="amd64 ~arm ppc x86 ~amd64-linux ~x86-linux"
15 IUSE="static-libs"
16
17 DEPEND="sys-libs/ncurses:="
18 RDEPEND="${DEPEND}"
19
20 S=${WORKDIR}/libtecla
21
22 PATCHES=(
23         "${FILESDIR}"/${PN}-1.6.1-install.patch
24         "${FILESDIR}"/${PN}-1.6.1-no-strip.patch
25         "${FILESDIR}"/${PN}-1.6.3-ldflags.patch
26         "${FILESDIR}"/${PN}-1.6.3-prll-build.patch
27         "${FILESDIR}"/${PN}-1.6.1-prll-install.patch
28         "${FILESDIR}"/${PN}-1.6.3-static-libs.patch
29         "${FILESDIR}"/${PN}-1.6.3-secure-runpath.patch
30 )
31
32 src_prepare() {
33         default
34         mv configure.in configure.ac || die
35         eautoreconf
36 }
37
38 src_configure() {
39         econf $(use_enable static-libs)
40 }
41
42 src_compile() {
43         emake \
44                 OPT="" \
45                 LDFLAGS="${LDFLAGS}" \
46                 LFLAGS="$(raw-ldflags)"
47 }