Use https by default
[gentoo.git] / dev-libs / libtar / libtar-1.2.20-r3.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 AUTOTOOLS_AUTORECONF=1
8 inherit autotools-utils
9
10 DESCRIPTION="C library for manipulating tar archives"
11 HOMEPAGE="http://www.feep.net/libtar/ http://repo.or.cz/w/libtar.git/"
12 SRC_URI="https://dev.gentoo.org/~pinkbyte/distfiles/snapshots/${P}.tar.gz"
13
14 LICENSE="GPL-2"
15 SLOT="0"
16 KEYWORDS="amd64 ~ppc ~ppc64 sparc x86 ~amd64-fbsd ~amd64-linux ~x86-linux ~ppc-macos"
17 IUSE="static-libs zlib"
18
19 RDEPEND="zlib? ( sys-libs/zlib )
20         !zlib? ( app-arch/gzip )"
21 DEPEND="${RDEPEND}"
22
23 S="${WORKDIR}/${PN}"
24
25 PATCHES=(
26         "${FILESDIR}"/${PN}-1.2.11-free.patch
27         "${FILESDIR}"/${PN}-1.2.11-impl-dec.patch
28         "${FILESDIR}"/CVE-2013-4420.patch
29 )
30
31 src_prepare() {
32         sed -i \
33                 -e '/INSTALL_PROGRAM/s:-s::' \
34                 {doc,lib{,tar}}/Makefile.in || die
35
36         autotools-utils_src_prepare
37 }
38
39 src_configure() {
40         local myeconfargs=(
41                 --disable-encap
42                 --disable-epkg-install
43                 $(use_with zlib)
44         )
45
46         autotools-utils_src_configure
47 }
48
49 src_install() {
50         autotools-utils_src_install
51
52         dodoc ChangeLog* README TODO
53         newdoc compat/README README.compat
54         newdoc compat/TODO TODO.compat
55         newdoc listhash/TODO TODO.listhash
56 }