dev-lisp/sbcl: Updating ebuilds to EAPI 6
[gentoo.git] / dev-libs / libstrl / libstrl-0.5.1.ebuild
1 # Copyright 1999-2013 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=4
6
7 inherit autotools-utils multilib
8
9 DESCRIPTION="Compat library for functions like strlcpy(), strlcat(), strnlen(), getline(), and asprintf()"
10 HOMEPAGE="http://ohnopub.net/~ohnobinki/libstrl/"
11 SRC_URI="ftp://mirror.ohnopub.net/mirror/${P}.tar.bz2"
12
13 LICENSE="LGPL-3"
14 SLOT="0"
15 KEYWORDS="amd64 x86 ~amd64-linux ~x64-macos"
16 IUSE="doc static-libs test"
17
18 # block various versions of opendkim for bug #454938 and bug #441790.
19 DEPEND="doc? ( app-doc/doxygen )
20         test? ( dev-libs/check )
21         !=mail-filter/opendkim-2.7.0 !=mail-filter/opendkim-2.7.1 !=mail-filter/opendkim-2.7.2"
22 RDEPEND="!=mail-filter/opendkim-2.7.0 !=mail-filter/opendkim-2.7.1 !=mail-filter/opendkim-2.7.2"
23
24 src_configure() {
25         local myeconfargs=(
26                 $(use_with doc doxygen)
27                 $(use_with test check)
28         )
29
30         autotools-utils_src_configure
31 }