dev-libs/libsodium: keywording arm64
[gentoo.git] / dev-libs / libsodium / libsodium-1.0.2.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 inherit eutils
8
9 DESCRIPTION="A portable fork of NaCl, a higher-level cryptographic library"
10 HOMEPAGE="https://github.com/jedisct1/libsodium"
11 SRC_URI="http://download.libsodium.org/${PN}/releases/${P}.tar.gz"
12
13 LICENSE="ISC"
14 SLOT="0/13"
15 KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sparc x86 ~amd64-linux ~x86-linux"
16 IUSE="+asm minimal static-libs +urandom"
17
18 src_configure() {
19         local myconf
20
21         # --disable-pie needed on x86, bug #512734
22         use x86 && myconf="${myconf} --disable-pie"
23
24         econf \
25                 $(use_enable asm) \
26                 $(use_enable minimal) \
27                 $(use_enable !urandom blocking-random) \
28                 $(use_enable static-libs static) \
29                 ${myconf}
30 }
31
32 src_install() {
33         default
34         prune_libtool_files
35 }