dev-libs/libsodium: fix AES-NI support
[gentoo.git] / dev-libs / libsodium / libsodium-1.0.15-r1.ebuild
1 # Copyright 1999-2018 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit eutils autotools
7
8 DESCRIPTION="A portable fork of NaCl, a higher-level cryptographic library"
9 HOMEPAGE="https://github.com/jedisct1/libsodium"
10 SRC_URI="http://download.libsodium.org/${PN}/releases/${P}.tar.gz"
11
12 LICENSE="ISC"
13 SLOT="0/23"
14 KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~mips ppc ppc64 s390 sparc x86 ~amd64-linux ~x86-linux"
15 IUSE="+asm minimal static-libs +urandom cpu_flags_x86_sse4_1 cpu_flags_x86_aes"
16
17 PATCHES=( "${FILESDIR}"/${PN}-1.0.10-cpuflags.patch )
18
19 src_prepare() {
20         default
21         eautoreconf
22 }
23
24 src_configure() {
25         local myconf
26
27         # --disable-pie needed on x86, bug #512734
28         use x86 && myconf="${myconf} --disable-pie"
29
30         econf \
31                 $(use_enable asm) \
32                 $(use_enable minimal) \
33                 $(use_enable !urandom blocking-random) \
34                 $(use_enable static-libs static) \
35                 $(use_enable cpu_flags_x86_sse4_1 sse4_1) \
36                 $(use_enable cpu_flags_x86_aes aesni) \
37                 ${myconf}
38 }
39
40 src_install() {
41         default
42         prune_libtool_files
43 }