dev-libs/libsigsegv: keyword ~arm64
[gentoo.git] / dev-libs / libsigsegv / libsigsegv-2.11.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 DESCRIPTION="Library for handling page faults in user mode"
7 HOMEPAGE="http://www.gnu.org/software/libsigsegv/"
8 SRC_URI="mirror://gnu/libsigsegv/${P}.tar.gz"
9
10 LICENSE="GPL-2"
11 SLOT="0"
12 KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
13 IUSE=""
14
15 src_configure () {
16         econf --enable-shared || die "Configure phase failed"
17 }
18
19 src_test () {
20         if [[ ${FEATURES} = *sandbox* ]] ; then
21                 # skip tests as they will fail
22                 return 0
23         fi
24         emake check ||  die "Tests failed"
25 }
26
27 src_install() {
28         emake DESTDIR="${D}" install || die "emake install failed"
29         dodoc AUTHORS ChangeLog* NEWS PORTING README
30 }