dev-libs/libsigc++: amd64 stable, bug 587010
[gentoo.git] / dev-libs / libsigc++ / libsigc++-2.8.0.ebuild
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=6
6 inherit eutils gnome2 flag-o-matic multilib-minimal
7
8 DESCRIPTION="Typesafe callback system for standard C++"
9 HOMEPAGE="http://libsigc.sourceforge.net/"
10
11 LICENSE="LGPL-2.1+"
12 SLOT="2"
13 KEYWORDS="alpha amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
14 IUSE="doc static-libs test"
15
16 RDEPEND=""
17 DEPEND="sys-devel/m4"
18 # Needs mm-common for eautoreconf
19
20 src_prepare() {
21         # don't waste time building examples
22         sed -i 's|^\(SUBDIRS =.*\)examples\(.*\)$|\1\2|' \
23                 Makefile.am Makefile.in || die "sed examples failed"
24
25         # don't waste time building tests unless USE=test
26         if ! use test ; then
27                 sed -i 's|^\(SUBDIRS =.*\)tests\(.*\)$|\1\2|' \
28                         Makefile.am Makefile.in || die "sed tests failed"
29         fi
30
31         gnome2_src_prepare
32 }
33
34 multilib_src_configure() {
35         filter-flags -fno-exceptions #84263
36
37         ECONF_SOURCE="${S}" gnome2_src_configure \
38                 $(multilib_native_use_enable doc documentation) \
39                 $(use_enable static-libs static)
40 }
41
42 multilib_src_install() {
43         gnome2_src_install
44 }
45
46 multilib_src_install_all() {
47         einstalldocs
48
49         # Note: html docs are installed into /usr/share/doc/libsigc++-2.0
50         # We can't use /usr/share/doc/${PF} because of links from glibmm etc. docs
51         if use doc ; then
52                 insinto /usr/share/doc/${PF}
53                 doins -r examples
54         fi
55 }