sys-block/btrace: Merge GitHub PR #1716
[gentoo.git] / dev-libs / libsigc++ / libsigc++-1.2.7.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6 GCONF_DEBUG="yes"
7 GNOME_TARBALL_SUFFIX="bz2"
8
9 inherit autotools gnome2 eutils
10
11 DESCRIPTION="Typesafe callback system for standard C++"
12 HOMEPAGE="http://libsigc.sourceforge.net/"
13
14 LICENSE="GPL-2 LGPL-2.1+"
15 SLOT="1.2"
16 KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sh sparc x86"
17 IUSE=""
18
19 DEPEND="sys-devel/m4"
20 RDEPEND=""
21
22 src_prepare() {
23         DOCS="AUTHORS ChangeLog FEATURES IDEAS README NEWS TODO"
24
25         # fixes bug #219041
26         sed -e 's:ACLOCAL_AMFLAGS = -I $(srcdir)/scripts:ACLOCAL_AMFLAGS = -I scripts:' \
27                 -i Makefile.{in,am}
28
29         # fixes bug #469698
30         sed -e 's:AM_CONFIG_HEADER:AC_CONFIG_HEADERS:g' -i configure.in || die
31
32         # Fix duplicated file installation, bug #346949
33         epatch "${FILESDIR}/${P}-fix-install.patch"
34
35         eautoreconf
36         gnome2_src_prepare
37 }
38
39 src_configure() {
40         gnome2_src_configure \
41                 --enable-maintainer-mode \
42                 --enable-threads
43 }