media-libs/portaudio: Version bump
[gentoo.git] / dev-libs / librevenge / librevenge-0.0.4.ebuild
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=6
6
7 inherit multilib-minimal
8
9 DESCRIPTION="A helper library for REVerse ENGineered formats filters"
10 HOMEPAGE="http://sf.net/p/libwpd/librevenge"
11 if [[ ${PV} == "9999" ]] ; then
12         EGIT_REPO_URI="git://git.code.sf.net/p/libwpd/librevenge"
13         inherit git-r3 autotools
14         KEYWORDS="hppa ppc64"
15 else
16         SRC_URI="http://sf.net/projects/libwpd/files/${PN}/${P}/${P}.tar.xz"
17         KEYWORDS="~alpha amd64 ~arm hppa ~mips ppc64 x86 ~x86-fbsd"
18 fi
19
20 LICENSE="|| ( MPL-2.0 LGPL-2.1 )"
21 SLOT="0"
22 IUSE="doc test"
23
24 RDEPEND="
25         dev-libs/boost:=
26         sys-libs/zlib[${MULTILIB_USEDEP}]
27 "
28 DEPEND="${RDEPEND}
29         doc? ( app-doc/doxygen )
30         test? ( dev-util/cppunit[${MULTILIB_USEDEP}] )
31 "
32
33 src_prepare() {
34         default
35         [[ ${PV} = 9999 ]] && eautoreconf
36 }
37
38 multilib_src_configure() {
39         ECONF_SOURCE=${S} \
40         econf \
41                 --disable-static \
42                 --disable-werror \
43                 $(use_with doc docs) \
44                 $(use_enable test tests)
45 }
46
47 multilib_src_install_all() {
48         find "${D}" -name '*.la' -delete || die
49 }